Withdrawal Delays: Stellar Network(USDC.XLM/XLM)

Incident Report for Zero Hash

Resolved

This incident has been resolved.
Posted Apr 12, 2026 - 21:22 UTC

Identified

We have seen an increase in delays regarding the processing of USDC.XLM and XLM withdrawals. The issue has been traced back to our MPC provider, and we are currently working closely with them to remediate the situation.
Posted Apr 12, 2026 - 20:56 UTC
This incident affected: SDK (DEPOSIT & WITHDRAWAL) and Core Resources (DEPOSIT & WITHDRAWAL).