PROD ETH/ ERC-20 withdrawal delays

Incident Report for Zero Hash

Resolved

This incident has been resolved. Impacted withdrawals are now processed and confirmed on chain.
Posted Oct 11, 2025 - 05:10 UTC

Update

A solution is being implemented to expedite delayed ETH & ERC-20 transactions.
Posted Oct 11, 2025 - 02:51 UTC

Identified

Our team noticed a delay in processing ETH/ERC-20 crypto withdrawals. We have identified the issue and a fix is being implemented. We apologize for any inconvenience. We will keep you posted for any updates.
Posted Oct 10, 2025 - 23:20 UTC
This incident affected: PROD - Deposits & Withdrawals (PROD - Digital Asset Withdrawals).