Delayed Crypto Withdrawals and Deposits

Incident Report for Zero Hash

Resolved

This incident has been resolved. All delayed withdrawals and deposits are processed. Thanks for your patience.
Posted Jul 23, 2025 - 03:07 UTC

Monitoring

A fix has been implemented and we are monitoring the results. Most of the delayed withdrawals and deposits have been processed and we will update the status once all clear.
Posted Jul 23, 2025 - 01:54 UTC

Identified

Our team is aware of delays with processing crypto withdrawals, and we are actively investigating. All impacted transactions will be confirmed on-chain once the incident has been resolved. We will provide updates as soon as we can.
Posted Jul 23, 2025 - 00:20 UTC
This incident affected: PROD - Deposits & Withdrawals (PROD - Digital Asset Withdrawals).