All delayed withdrawals have been processed and incoming transactions are being processed as normal now. Issue is resolved. Thanks for your patience while we worked through this.
Posted Jan 28, 2026 - 02:40 UTC
Monitoring
A fix has been implemented and we've seen delayed transactions processing as expected. We are monitoring the queue of delayed transactions and will confirm once all have been processed.
Posted Jan 28, 2026 - 01:21 UTC
Update
We are still actively working with our MPC provider to resolve the delayed BTC withdrawals. Unfortunately, we do not have an ETA this moment, but will provide additional updates as soon as we can.
Posted Jan 28, 2026 - 00:38 UTC
Investigating
We are aware of a delay of processing Bitcoin (BTC) crypto withdrawals. We are actively investigating the issue with our MPC provider, and will provide updates as soon as we can. Impacted transactions will be sent on-chain automatically following issue resolution.
Posted Jan 27, 2026 - 22:44 UTC
This incident affected: Core Resources (DEPOSIT & WITHDRAWAL).