Delayed ETH Withdrawals & Deposits

Incident Report for Zero Hash

Resolved

All impacted transactions have now been confirmed on-chain.
Posted May 22, 2026 - 17:03 UTC

Identified

We are aware of a delay of processing Ethereum (ETH) crypto withdrawals. We have identified the issue and are currently working on a fix. Impacted transactions will be confirmed on-chain automatically following issue resolution.
Posted May 22, 2026 - 16:51 UTC
This incident affected: Core Resources (DEPOSIT & WITHDRAWAL).