Intermittent Delays Processing LTC Withdrawals
Incident Report for Zero Hash
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 17:35 CDT
Investigating
We are working with our MPC technology provider to investigating an issue with processing LTC withdrawals. Withdrawals will be re-sent on-chain automatically following issue resolution.
Posted Apr 22, 2024 - 13:23 CDT