ETH / ERC-20 Withdrawal Delays

Incident Report for Zero Hash

Resolved

All impacted transactions have now been confirmed on-chain.
Posted Oct 10, 2025 - 16:51 UTC

Investigating

Our team is aware of a delay in processing ETH / ERC-20 withdrawals and are actively investigating. All impacted transactions will be confirmed on-chain automatically following issue resolution.
Posted Oct 10, 2025 - 16:23 UTC
This incident affected: PROD - Deposits & Withdrawals (PROD - Digital Asset Withdrawals).