Crypto Withdrawal Delays

Incident Report for Zero Hash

Resolved

This incident has been resolved.
Posted 2 months ago. Jan 30, 2025 - 00:06 UTC

Update

We are still working with our MPC provider to resolve the remaining queue of delayed withdrawals. New transactions are being processed as expected.
Posted 2 months ago. Jan 29, 2025 - 23:14 UTC

Monitoring

Our MPC provider is working through an issue that is causing crypto withdrawal delays across multiple networks. Our team is monitoring the delays, and all impacted withdrawals will be confirmed on-chain once the incident is resolved..
Posted 2 months ago. Jan 29, 2025 - 20:01 UTC
This incident affected: PROD - Deposits & Withdrawals (PROD - Digital Asset Withdrawals).