BTC Withdrawal Delays Due to Gas Spike
Incident Report for Zero Hash
Resolved
This incident has been resolved.
Posted Jun 08, 2024 - 06:49 UTC
Monitoring
Our team is aware of delays with processing Bitcoin (BTC) withdrawals due to a gas spike. Impacted withdrawals will be confirmed on-chain once gas prices come back down.
Posted Jun 07, 2024 - 17:22 UTC