Withdrawals delayed

Incident Report for Zero Hash

Resolved

This incident has been resolved.
Posted Dec 05, 2022 - 21:24 UTC

Investigating

We are experiencing delays in sending withdrawals on-chain. We are investigating this issue.
Posted Dec 05, 2022 - 20:37 UTC
This incident affected: PROD - Deposits & Withdrawals (PROD - Digital Asset Withdrawals).