BTC Withdrawal Delays Due to Network Fee Spike
Incident Report for Zero Hash
Resolved
This incident has been resolved.
Posted Aug 22, 2024 - 14:32 UTC
Monitoring
Our team is aware of delays with processing withdrawals on BTC due to a spike in network fees. Impacted withdrawals will be confirmed on-chain once fees come back down.
Posted Aug 22, 2024 - 13:42 UTC