Intermittent delays processing withdrawals
Incident Report for Zero Hash
Resolved
This incident has been resolved.
Posted Apr 25, 2023 - 19:38 CDT
Investigating
We are investigating delays in processing crypto withdrawals.

Deposits, executions and trades are unaffected.
Posted Apr 25, 2023 - 16:04 CDT
This incident affected: PROD - Deposits & Withdrawals (PROD - Digital Asset Withdrawals).