Delays in processing Crypto Withdrawals

Incident Report for zerohash

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 15:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2026 - 15:03 UTC

Identified

Update: The issue stems to our MPC provider partner which is currently experiencing in processing outgoing transactions. Multiple crypto currencies are now affected by these delays.
Posted Jun 22, 2026 - 14:50 UTC

Update

We are continuing to investigate this issue.
Posted Jun 22, 2026 - 14:34 UTC

Investigating

We've noticed an increased delay in processing Solana Withdrawals. Our team is now currently investigating.
We will keep you posted.
Posted Jun 22, 2026 - 14:34 UTC
This incident affected: SDK (DEPOSIT & WITHDRAWAL) and Core Resources (DEPOSIT & WITHDRAWAL).