Intermittent Delays on Withdrawal Confirmation
Incident Report for Zero Hash
Resolved
Our MPC Technology provider's issue is resolved & all impacted withdrawals are out on chain.
Posted Apr 16, 2023 - 12:50 CDT
Investigating
Intermittent delays identified on withdrawals confirmation. We are investigating in conjunction with our MPC technology provider.
Posted Apr 16, 2023 - 11:58 CDT