Ethereum Network Scheduled Upgrade
Scheduled for Jun 29, 04:45 CDT  -  Jun 30, 00:45 CDT
Update
Reminder Ethereum network will be undergoing a scheduled network upgrade at block 15,050,000( ~ 5:45 AM EST )
Posted Jun 28, 2022 - 15:00 CDT
Scheduled
The Ethereum network will be undergoing a scheduled upgrade around Wednesday June 29th, 2022 (the Gray Glacier hard fork at block 15,050,000).

We anticipate no disruption to our service before, during and after the upgrade. However, there is still a network-wide risk to consider that is outside our control.

We recommend customers to monitor the status of the network during this time, as well as not making time sensitive deposits or withdrawals immediately after (e.g. for 2 hours either direction) if possible.

With an average of 14.4 seconds per block, the fork is currently expected to happen around Wed Jun 29 2022 09:45 UTC/04:45 CDT.

For more details, please refer to https://blog.ethereum.org/2022/06/16/gray-glacier-announcement/
Posted Jun 21, 2022 - 12:16 CDT