Delayed ETH / ERC-20 Withdrawals

Incident Report for Zero Hash

Resolved

All impacted transactions have now been confirmed on-chain.
Posted Nov 20, 2025 - 18:37 UTC

Investigating

We are aware of a delay of processing ETH / ERC-20 crypto withdrawals. We are actively investigating the issue with our MPC provider, and will provide updates as soon as we can. Impacted transactions will be sent on-chain automatically following issue resolution.
Posted Nov 20, 2025 - 17:47 UTC
This incident affected: PROD - Deposits & Withdrawals (PROD - Digital Asset Withdrawals).