ETH/ERC20 Delayed Withdrawals

Incident Report for Zero Hash

Resolved

Issues with withdrawals has been resolved, and delayed withdrawals have been processed. We will continue to actively monitor for any further disruptions.
Posted May 27, 2023 - 03:34 UTC

Investigating

We are investigating delays in processing ETH/ERC20 crypto withdrawals.
Posted May 27, 2023 - 02:51 UTC
This incident affected: PROD - Deposits & Withdrawals (PROD - Digital Asset Withdrawals).