Intermittent delays processing withdrawals, deposits, executions and trades
Incident Report for Zero Hash
Resolved
This incident has been resolved.
Posted Jun 12, 2024 - 20:46 UTC
Update
a fix has been implemented and we are continuing to monitor the results
Posted Jun 12, 2024 - 16:08 UTC
Monitoring
We are investigating delays in processing crypto withdrawals, deposits, executions and trades
Posted Jun 12, 2024 - 14:36 UTC