We have applied fix and the issue is now resolved. Most of the delayed withdrawals have been processed and the rest will be going out in the next few minutes. Thanks for your patiences.
Posted Jun 09, 2025 - 02:35 UTC
Monitoring
We identified the the issue and applying the current fix. We are monitoring the results. Withdrawal delays are now decreasing.
Posted Jun 09, 2025 - 00:31 UTC
Investigating
Update: Re-opening the incident to investigate the wider impact. Our team is currently investigating the root cause and working on a resolution.
Next Steps: We will provide regular updates on our progress and notify you as soon as the issue is resolved.
Affected Systems: Crypto withdrawal processing
We apologize for any inconvenience this may cause and appreciate your patience as we work to resolve the issue. If you have any questions or concerns, please don't hesitate to reach out.