Client Portal Not Loading

Incident Report for Zero Hash

Resolved

We have resolved the issue and Client Portal is now back to normal. Thanks for your patience while we worked through the issue.
Posted Mar 01, 2026 - 23:11 UTC

Investigating

We are investigating an issue preventing users from accessing portal.zerohash.com

We will provide updates as they become available.
Posted Mar 01, 2026 - 22:42 UTC
This incident affected: Web Applications (Client Portal).