Degraded Client Portal Performance

Incident Report for Zero Hash

Resolved

A fix has been implemented and our Client Portal is functioning as expected.
Posted May 29, 2026 - 00:48 UTC

Investigating

We are investigating an issue preventing users from accessing the Client Portal; API calls are not impacted.

We will provide updates as they become available
Posted May 28, 2026 - 23:22 UTC
This incident affected: Web Applications (Client Portal).