New Incident: Delayed Withdrawals
Incident Report for Zero Hash
Resolved
Issues with withdrawals has been resolved, and delayed withdrawals have been processed. We will continue to actively monitor for any further disruptions.
Posted May 18, 2023 - 23:44 CDT
Monitoring
A fix has been implemented by our MPC Technology provider to resolve the issue & we are currently monitoring the results.
Posted May 18, 2023 - 21:27 CDT
Investigating
We are currently investigating the issue
Posted May 18, 2023 - 17:59 CDT
This incident affected: PROD - Deposits & Withdrawals (PROD - Digital Asset Withdrawals).