Delayed BTC Withdrawals

Incident Report for Zero Hash

Resolved

All impacted transactions have now been confirmed on-chain.
Posted Apr 03, 2026 - 18:50 UTC

Identified

We are aware of a delay of processing BTC crypto withdrawals. We are actively investigating the issue with our MPC provider, and will provide updates as soon as we can. Impacted transactions will be confirmed on-chain automatically following issue resolution.
Posted Apr 03, 2026 - 17:45 UTC
This incident affected: Core Resources (DEPOSIT & WITHDRAWAL).