Intermittent delays impacting settlement and convert withdrawals
Incident Report for Zero Hash
Resolved
This incident has been resolved, thank you for your patience.
Posted Jun 05, 2024 - 04:21 UTC
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Jun 05, 2024 - 03:08 UTC
Investigating
We are investigating delays in settlement and processing crypto withdrawals. We apologise for any inconvenience.
Posted Jun 05, 2024 - 02:05 UTC