Delays in processing Crypto Withdrawals

Incident Report for Zero Hash

Resolved

This incident has been resolved.
Posted Jun 07, 2026 - 14:44 UTC

Monitoring

A fix has been implemented by our MPC provider. We are now monitoring the results
Posted Jun 07, 2026 - 12:17 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 07, 2026 - 11:58 UTC

Identified

Our team noticed a delay in crypto withdrawals and upon further investigation, this was caused by our MPC provider. We are working closely with them to resolve this issue. Thank you for your patience.
Posted Jun 07, 2026 - 11:57 UTC
This incident affected: SDK (DEPOSIT & WITHDRAWAL) and Core Resources (DEPOSIT & WITHDRAWAL).